Commit eefb75b8 authored by rakshasa's avatar rakshasa

Added support for gcc-4.7 in travis.

parent fc7bcbe8
......@@ -7,11 +7,12 @@ before_install:
- sudo add-apt-repository --yes ppa:ubuntu-toolchain-r/test
- sudo apt-get update -qq
- sudo apt-get build-dep libtorrent-dev
if [ "$CXX" = "g++" ]; then sudo apt-get install -qq g++-4.7; fi
if [ "$CXX" = "g++" ]; then export CXX="g++-4.7" CC="gcc-4.7"; fi
# prevent `macro `AM_PATH_CPPUNIT' not found in library` in `autogen.sh`
- sudo apt-get install libcppunit-dev
# - sudo apt-get install libcppunit-dev gcc-4.7 g++-4.7
# `autogen.sh` doesn't call `configure`
# - export CC=gcc-4.7 && export CXX=g++-4.7
# Figure out how to fix the issue running 'make check'.
script: ./autogen.sh && ./configure && make -j12 check && sudo make install
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment